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Version 2.00
This guide describes the installation and functionality of the OpenProtocols for Microsoft Outlook.

Features
The OpenProtocols Connector for Microsoft Outlook has the following features:





Full integration of email, appointments, tasks and address book
Access the global address directory if available
Offline support
Support for SSL connections to the server

Requirements
The server needs to support IMAP for email, CalDAV for calendaring and CardDAV for contacts. If the
CardDAV server supports a global directory, this will be available. For the client application, you can use the
following:





Microsoft Outlook 2003 (with Office SP3)
Microsoft Outlook 2007
Microsoft Outlook 2010 (32bit and 64bit versions)
Microsoft Outlook 2013 (32bit and 64bit versions)

Installation
Close Microsoft Outlook and run the installation application for the connector.

Server Configuration
The OpenProtocols connector communicates to the mail server via the IMAP and SMTP services. A default
installation would require the client machine to access the server over ports 143 and 25, although this is
configurable. If SSL is being used, the client port configuration must match the server SSL port configuration.

Creating an Account
Adding an account to an existing profile in Outlook 2007:
1.
2.
3.
4.

Select Account Settings from the Tools menu.
Select the New... link to create a new account.
Select Other and the Open Protocols Server option, then select Next.
You can now configure the account as per the steps in Configuring an Account.

Adding an account to an existing profile in Outlook 2010:
1.
2.
3.
4.

Select the File menu item and click the Add Account button under the Account Information heading
Select the Manually configure server settings of additional server types option, then select Next.
Select Other and the Open Protocols Server option, then select Next
You can now configure the account as per the steps in Configuring an Account.

Adding an account to an existing profile in Outlook 2013:

1.
2.
3.
4.

Select the File menu item and click the Add Account button under the Account Information heading
Select the Manual setup or additional server types option, then select Next.
Select Other and the Open Protocols Server option, then select Next
You can now configure the account as per the steps in Configuring an Account.

Configuring an Account
You can now configure the settings for connecting and accessing the mail server. For simple account
configuration you only need to fill out the data on the General tab.

Option
Email Address
Password
Detect Settings

Server Address
User Name

Description
The email address that will be used to send the email.
The mailbox password.
This button can be clicked in order to have the connector try to auto-fill the
rest of the account details. The email address will be used to determine the
rest of the settings.
The domain or the IP address of the mail server.
The username for the mailbox to log into.

Your Name
Account Description
Enable advanced
configuration

This is the friendly name which is show on the emails being send, normally the
first name and surname.
A name to identify the mailbox, and is the name Outlook displays when listing
the account.
When enabled, this will show other configuration tab pages where more
advanced options can be configured.

The Mailbox tab allows more advanced options with the mailbox connections to be set:

Option
Server Address
Port Number

Use SSL
User Name
Password

Description
The domain or the IP address of the mail server.
The port that the connector will connect to on the server. The connector needs
to connect to the IMAP service running on the server, so this would normally
be 143. For SSL this is normally 993.
If SSL is configured on the IMAP service then you are able to enable this.
The username for the mailbox to log into.
The mailbox password.

The Outbound tab allows you to configure extra outbound options:

Option
Sender Name
Email Address
Reply To Address
Send mail on behalf of
another person

Display Name
Email Address
Use same settings as for
mailbox connection

Description
This is the friendly name which is show on the emails being send, normally the
first name and surname.
The email address to send as.
The email address to be used as the Reply-To address in the emails sent.
Normally this will be the same as the email address.
This option is select if you want to send email on behalf of someone else. This
changes the From address in the email header to be the display name and
email address configured here, and uses the sender name and email address as
the Sender address in the email header.
The friendly name to be used for the From address when sending on behalf of
someone.
The email address to be used for the From address when sending on behalf of
someone.
Usually when sending email you would authenticate using the same mailbox
details as you are logging in for, so this option would be enabled. If you need
to authenticate as another user when sending email you can set the options

Server Address
Port Number
Use SSL
Account Name
Password

here.
The domain or the IP address of the mail server.
The port number of the SMTP service.
If SSL is configured on the server for an SMTP port, you can select it here.
The username to authenticate with.
The password to authenticate with.

The Connection table allows the changing of connection specific options:

Option
Update folders at startup

Download entire
messages

Description
If this is enabled, when Outlook is started the client will check every server
folder and sync these with the client. This will slow down opening the account
initially, but may help if the mailbox has other users who access it at the same
time.
If you have a fast link to the mail server (if it was on your local network), then
selecting this option will help reduce delays when new messages arrive, as the
connector will try to download the full message as soon as it is available. By
default the connector will only download some of the message details until the
message is selected.

The Troubleshooting tab is used to configure options for diagnosing problems:

Option
Troubleshooting mode

Disable concurrent
downloading and
synchronisation
Enable logging

Logging level
New files each session

Automatically update

Description
When enabled, more work is done when syncing the client cache with the
server content, to make sure they match. This slows down any
synchronisation, so only enable if requested to.
This will force the connector to only process one folder at a time. Only enable
if instructed to, as it will slow down the synchronisation process.
The connector has extensive logging, which is designed to help the support
team to diagnose any issues. Log files can get very large (gigabytes in size if
Outlook is left running for a while), so only enable this if instructed to by a
support person, and make sure you disable when the required logs are
generated.
How much information will be logged to the log files. Full Detail will generate
large log files.
Whenever Outlook is started with logging turned on, the log file will be
overwritten. If you want to keep log files whenever closing and opening
Outlook you will need to enable this option.
Updating Outlooks contact labels immediately adds some overhead to the

contact address labels
Automatically check for
software updates

connection, so it is able to be disabled here to improve performance if needed.
When Microsoft Outlook is started, the connector will check to see whether a
new version of the connector is available. It is able to then download this for
you and start the installation process.

Initial Connection
When a connection is first made to the mail server by the client connector, all the mailbox contents from the
server are copied to the local profile. If you are connecting to a mailbox with a lot of email data, be aware
that it can take time to do the initial connection.

Outlook Menu
The connector adds another ribbon bar item to Outlook, called Server. The following items can be accessed:
Refresh Folder List: Synchronises the list of folders between the client and the server.
Reset Folder From Server: Empties the currently selected folder from the client and downloads the contents
from the server.
Check Folder for New Messages: Performs a synchronisation with the server on the currently selected
folder, checking whether it is up to date, and downloading any missing messages, updating changed
messages, and removing deleted messages.

Offline Support
When a connection is not available to the server, you are still able to use Microsoft Outlook to read, reply
and to change flags for messages (the message has to have previously been downloaded to Outlook for this
to work). You are not able to do folder manipulation or delete messages. Appointments, tasks and contacts
can be created and edited. When a server connection is available again, your previous changes will be
synchronised with the server.

Server Folder Synchronisation
The mail server does not give notifications of folder changes, such as new folders, or removing folders. So if
you remove a folder in webmail while you have an Outlook connector client connected, it will not know the
folder has been removed, and it will still be visible. In order to have the client update the folders, go into the
account settings and click the Enable advanced configuration checkbox. Then click the Connection tab that
appears and select the Update folders at startup checkbox. This will force Outlook to check the folders on
the server when Outlook is opened.

Microsoft Outlook Add-ins
Much of the behaviour provided by the connector is by Outlook add-ins. There are two alternative add-ins,
an Exchange Client Extension (not available in Outlook 2010), and a COM add-in. They both provide the same
features. If neither add-in is enabled, you will not have the full synchronisation experience. The procedure
for checking the state of the add-ins and enabling them varies with different versions of Outlook.
For Outlook 2003:
Select the Tools > Options menu. Click the Other tab in the window that appears, click the Advanced
Options button. Select the Add-In Manager button. In the Add-In Manager window that opens, find the
"MailEnable" entry and ensure it is ticked to enable it.

For Outlook 2007:
Go to the Tools menu and select the Trust Center. In the list on the left of the "Trust Center" window, select
Add-ins. In the drop down list labelled "Manage:" at the bottom of the right hand panel, select Exchange
Client Extensions and click the Go button. In the Add-In Manager window that opens, find the "MailEnable"
entry and ensure it is ticked to enable it. If it is not visible, then click the Add… button and select the
MailEnableMS32.dll file from the Windows system32 directory (normally c:\Windows\system32).
For Outlook 2010/2013:
Go to the File menu and select Options. In the window which appears, select the Add-ins option. In the drop
down list labelled "Manage:" at the bottom of the right hand panel, select COM Add-ins and click the Go
button. In the "COM Add-Ins" dialog that opens, look for the option MailEnable Connector for Outlook Addin, and ensure it is ticked to enable it. If it is not visible, then click the Add… button and select the
MailEnableMS32.dll file from the Windows system32 directory (normally c:\Windows\system32).

Importing email data
You are able to import email from an existing PST file to an Outlook connector account. Be aware though
that when you do this, all the email being imported has to also be uploaded to the server. So importing large
mailboxes may take a long time, depending on the clients Internet connection.

Moving Outlook Connector PST files
It is not possible to change the location of a PST file once an account is created with the Outlook connector.
There is not a way to configure the location of the PST files, and the connector will always use the Windows
APPDATA environment variable to determine where to store the local cache.

Limitations
1. Messages that have not been downloaded from the server will show only their downloaded size
when sorting, not their complete size.
2. Exceptions to recurring appointments are only kept locally to Outlook. They are not shown in
webmail, as exceptions are not supported by webmail.
3. Mark All as Read for folder is not available.
4. Custom special folders are not supported by the connector. So you are unable to create your own
calendar, tasks or contact folders using the Connector.
5. If you are running a non-English version of Outlook, any secondary Connector accounts, or shares,
will have their special folders in English (i.e. you will have Calendar, Tasks, etc. in English).
6. The global directory is only loaded when Outlook starts. So new contacts added to the global
directory will not be visible immediately.
7. BCC addresses are not visible for messages in the Sent Items folder.
8. Outlook rules are not able to be processed unless Outlook is open at the time the message arrives. If
you use rules, after loading Outlook run the rules manually.

FAQ
Q. When trying to save a reminder, I get an error indicating that the folder does not support this type of
item.
A. Reminders are only supported on the default store for the profile you are using. If you are using
multiple accounts in a profile, you can change the default by using the Mail control panel applet.
Q. While composing a message with a large attachment, Outlook seems to freeze for a while.
A. The Connector will save a message being composed to the Drafts folder depending on your
Outlook settings. Since the Drafts folder is stored on the server, the Connector will be uploading it.
You can increase the time before Outlook saves to Drafts in the Outlook options.
Q. Which account are my Draft messages saved to?
A. If you have multiple email accounts configured under the one profile then draft messages will be
stored in the default account.

